MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
MadTrooper
Posts: 45
HI Guys, I have a little trouble with getting the Annouciators for the gears to show the right LEDs when they are UP, Moving and Down in the simulator. I'm using the Arduino mega 2560 with the latest Mobilflight firmware.

What I want to do is when the gears are down, then the Green LEDs are ON on pin number 2,3 and 4.
When activating the gear lever to bring the gears up, then the Green LEDs are turned OFF individually on pin number 2,3, and 4, and Red LEDs on pin number 5,6 and 7 are turned ON also individually to indicate gears are moving and then turned OFF when Gears are UP.

Samething when Gears lever is pulled down, All of the above is happening but in reverse and the end result would be 3 Green LEDs are ON and stay ON.

On the Mobiflight Modules page I have the following output devices mapped to pins and when individually tested the proper LEDs are fonctionning:

Gear nose down on pin number 2;
Gear left down on pin number 3;
Gear right down on pin number 4;
Gear nose moving on pin number 5;
Gear left moving on pin number 6; and
Gear right moving on pin number 7.

I have mapped all of those devices in the Mobiflight connector on the Output tab and tried it in the sim but the lights are not fonctionning like they should.

In the configWizard using the proper presets I have noticed that the same FSUIPC Offset is used for pin number 2 and 5 (0BEC), pin number 3 and 6 (0BF4) and pin number 4 and 7 (0BF0).

Is there something I'm missing? Do I have to insert some codes under the More Options tab?


Thanks for your help!


MadTrooper
2017-02-22 18:33
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3740
Supporter
Hi MadTrooper
I see there is a little "bug" in Mobiflight Presets here.... But no big problem.....

First question : WHAT Aircraft you want to controll ?? A Standard FSX Plane or a AddOn like PMDG, Prosim and so on ??

Standard Aircrafts ( and some Addons, too) use this descripted Standardoffsets ... 0BEC 0BF0 0BF4
These Offsets not direct shown the LED Status.... This show the Gear Status from UP =0 to Down = 16383 (16382 in some cases)
( thats why you got same offset for gear transition and Gear Down green/red cause both led´s work or go off if the value is in defined range )

Addons like PMDG additional gives a Offset for every LED ( 6 Offsets) that show a 1/0 Status if LED is On. here we not need theStandard Offsets.


Now the "bug"
While a Mobiflight Update the "Compare" Field have change ( The Area we can compare the value with a special function) . In Case of this changing the compares in Presets gets lost.... The field is empty now. (BUG)
To work with that offset for Red/Green LED we need to add this Compare Function now manualy......

Instuctions:

For the 3 Configs of "Gear Down" (Green) please insert in the Compare field ....
If current Value bigger >16380 THEN Value =1 Else 0
This say... If offsetstatus is bigger 16380 this means gear is down.... And we want the Green LED to light up here)
( We use this "bigger cause some Aricrafts not reach the 16383 Value exact.....)

For the 3 Configs of "Transit" (Red) please insert in the Compare field.....
if current Value bigger > 16380 Then Value = 0 (let the "Else" Field empty)
This say... On Value 0 (Gear Up) LED is off.... Range between Up and Down Value is bigger then 1 and LED is light up..... On Down ( Value bigger 16380 ) its 0 and off again.


Hope you understnad this stuff...... If you have questions or if it already not working please ask again.

@ Sebastian:
Please check Preset Compare Status.... Maby a issue while changing the "Transform field in 7.1 thks.
Good Luck !
2017-02-22 20:48
Avatar
MadTrooper
Posts: 45
HI Pizman82, Thanks to you now I understand. The compare fonctions are working for me on the latest 1firmware version. I used it and now all the gear lights are working as they should.

Thanks again for your help it is greatly apprciated.



MadTrooper
2017-02-22 22:13
icon