MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
ole@kvalsvik.nu
Posts: 3
Hi,
I`m totaly new to this Mobiflight but i like the idea and seems not to complicated to use.
i tested this the first time today and got an Arduino uno up and running with the firmware.
Did the quick tutorial with the brake light and botton.
Still not got any led segment displays yet to try but managed to get my Led light to interact with toggle the parking brake on and off.
I do also se changes in value received from x-plane in regards to heading data etc. etc.

The problem is that nothing is working the other way around. That i give x-plane an command to turn the brake off with the botton like in the tutorial.
also tried with rotary encoder to change the heading. Followed the guide from youtube video but nothing happens.

I have look around everywhere for what i do wrong but im stuck.

Please, can anyone help me.

I got a bunch bottons, lights, encoders, led displays arraving soon. :)

Thanks
2017-02-14 22:21
Avatar
pizman82
From: ETSI, Germany
Posts: 3732
Supporter
Do you use XPUIPC ?? http://www.tosi-online.de/XPUIPC/XPUIPC.html


What Plane are you testing ?? Sounds strange that you can Read Out data but not write it ?
Good Luck !
2017-02-15 18:58
Avatar
ole@kvalsvik.nu
Posts: 3
Hi

Yes i am using XPUIPC installed in x-plane 11 under plugins.
tried this witth the X-plane 11 737 plane.
And looks like i can read data.
have only tried yet the green light to light up when parking brake is on, and that i working.
also i ses some data coming in from heading but have not received my Led display yet to try it.
but can not write any data to the plane.
exp, turning the parking brake off.
nothing seems to work whatever switch i try.

FYI, Im using and Arudino Uno.
Tried an 2560 mega board i had but just got error message when loading firmware. might be an old version.
I have ordered new.

Do i have to set something up in x-plane to be able to write any data??
2017-02-15 23:11
Avatar
pizman82
From: ETSI, Germany
Posts: 3732
Supporter
iconole@kvalsvik.nu:


Do i have to set something up in x-plane to be able to write any data??



Hi.

I´m not specialist for Xplane. Don´t use it myself !

I know from others you have to edit the INI File and set your personal Network IP Adress there.... This is descripted in the XPUIPC Readme.txt file.
Not shure if this is needed for "writes" and "reads" work without ?? Please Check this youreself.

Maby the Big Problem is not Xplane.....
I read lots of Topics of last weeks that there are masiv problems with UNO and meanwhile with MEGA, too. Mobiflight did a big Patch 2 Weeks ago, that impliment UNO Support.... Looks this not realy work fine and crash MEGA support, sometimes too.

I think next days/weeks some hotfixes will help us. Maby you can try to downgrade the Software if you want to use youre MEGA Board. Just use a older Version before the trouble beginns.
Use Official Downloadlink but change version Number in Link.... Maby use 7.1.3.exe

Hope this help my friend !
Good Luck !
2017-02-16 06:07
Avatar
ole@kvalsvik.nu
Posts: 3
Sweet :)

Thanks mate

This did all the tricks needed.

Downloaded the 7.1.3 version and loaded the firmware to my 2560 board. Worked with no issues.
tried the parking brake program again with botton and lights. :)
It is working as it should.

The ip address correction for XPUIPC in the XML file i did before so that was not the issue,
So issue here must be in the newest version 7.2.2

Im sure there wil come an hotfix soon :)

Now i am really looking forward to receiveing all the parts for my 737 MCP.
2017-02-16 17:43
icon