MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
waviateur
Posts: 1
Hi, I am new to this forum, so maybe my problem is already solves in another thread.

I had a setup working with rotary encoders with solder pins.
I changed the encoders for encoder on a board with 5 pin connector.
But when I connect them the instrument on the aircraft will only rotate when I turn to the left, when I turn the encoder to the right nothing happens.
I use cheap encoders but I have the same problem with expensive Velleman encoders.

When I use the older encoders everything works normal.

2020-07-11 16:19
Avatar
RudyB
Posts: 27
Some possible causes that I can think of (there may be others):
- a wiring issue
- the encoder is broken (less probably because you have the same issue with Velleman, but still ...)
- the encoder type in the hardware setup menu > extra's > settings needs to be changed. There are 5 types to choose from.
Always have fun!
2020-07-11 20:35
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3527
Supporter
Hi

Not every encoder is compatible with Mobiflight..... specialy the 5 Pin ones "can" be problematic. E.g. the KY40 will work.

NOTE: The 5 Pin Encoders need also the Additonal 5v and GRD from the same arduino Board you use for the Data Pins.
Good Luck !
2020-07-11 21:54
icon