MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
horenh
Posts: 19
A few days ago i discontinued Mobiflight and saved the MCC file. Now i start Mobiflight again and have a big problem.

Mobiflight won't start with connected Arduino's. After searching for a while I come to the following conclusion.

When i remove the files:
MFConnector,exe,4304,dmp,
MFConnector.exe.log and from AppData\Local\Microsoft\CLR_V4.0_32\usageLogs
MFConnector.exe_Url_hcdoncnm3vlcibmq3lnsss31yivdtg5w from AppData\Local\Mibiflight
then start Mobiflight clean.
Then i load my MCC file and that gives a error. When i choice continu its working until I close Mobiflight.
The same result with the backup MCC file from a number of days back.

On this forum i have read something but no final solution

What can I do without make a compleet new MCC file for 6 Arduino's.
And the most important thing what did i wrong to prevent this error.


With Greating
Henny Horenberg
2019-09-26 21:23
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 2921
Supporter
Hi at first we must locate the problem.....

I never do a so difficult workflow like you.... some of the listed files i never heard about.
In most simmular cases the Problem is the MCC File itself.

Simply test this.....
Remove the MCC File you try to load in the problematic situation ( the same file Mobiflight try to AUTO LOAD at this moment after restart)
Copy it to a other spot ( so mobiflight can NOT find it at the old position) .
Then start Mobiflight.
If the MCC File is the issue then Mobiflight will start clean now and load a empty file or a old example file ( basic manifactur status) .

Please Confirm THIS is the issue !

**********************

If Yes the problem can occure in 2 ways.
1. in verry rare situations Mobiflight make those errors.... Never see it myself but i heard about.
2. in 99% of Situations the User make a wrong setting

Its not possible to tell you the exact spot of problem now.... Mostly this are issues while building.
For example you make a precondition ..... Then you don´t like/need it and you just disable it ( but not delete it)
Then you rename or delete the Config that was used for this precondition
Then a Error occure on next startup.... Cause Mobiflight see a precondition ( whatever not enabled) that is adressed to a config that not exist at this moment.
Same happen with wrong Transforms, Wrong Compares , Unlogical Interpolations and Placeholders .... And Again.... Whatever Enable or disable.... Both occure in a Error.


*************
To solve this you have two ways....
You can try to load the file by hand.... If Mobiflight bring a Error you are unlucky..... If you can open the file ( NOT start it) then you can check and rework your configs to find the problem.
If its not possible to load the file the only way is now to open the file with a text editor and try to find the issue in the code.


Basicly the best way to prevoent those situations is a perfect backup history. Not only a backup " form some days ago" .... You need a Backup from every step.... And you should save all backups single..... Then you can jump back 1,2,3, or more backups until the point the issue come into the system.
The other way is to work 100% correct..... As i said 99% of issues are done by the user.... make no issue result in no errors .

Last hint: The issue is pretty sure in a element you add at last before the problem start.... So you not need to check the whole file..... Check at first the last entrys you done.

Please report/Confirm that mcc file is the problem..... Try to find the issue ..... If you can´t solve this you can send me the file..... But it will take a long time to check this for me.
Good Luck !
2019-09-27 02:14
Avatar
horenh
Posts: 19
Thanx for the fast answer.
First off all I am very happy with mobiflight so i can make panels for the B737-800 PMDG.
and i am also impressed for the quick reaction on the forum.

What i really did in teh story above was remove the file User,config and thbus the path to the MCC files.
This morning it was clear that the MCC file was the cause.

What i did was copy the file in parts to a new file and then testing.
Finaly i did not encouter an error but afterwards it works well again.

Now on the Forward Overhead all switches, rotery, 7-segment display and LEDjes are working.

Thanx again
Henny Horenbegr
2019-09-27 13:43
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 2921
Supporter
iconhorenh:


What i did was copy the file in parts to a new file and then testing.
Finaly i did not encouter an error but afterwards it works well again.



I will say.... there MUST was something wrong, if it runs well now and occure in a error before.

But nice you can fix it.
Thats also the way i did at beginning.
If you understand the structure of the mcc file code, then you can select a single config or a couple of configs. ( you just need to know exactly in what line a config starts and ends)
I personaly start to split Inputs and Outputs, first ..... Then try single. Mostly issue is only in one part and i already know then the other is absolutly OK.
Then i split the broke part into 2 halfs and test again.....
With this technic you split config verry quickly form 100-50-25-12-6 % Size in only 4 Testruns and you can locate the problem spot .

Whatever.... It workes. Problem solved !
Good Luck !
2019-09-28 06:39
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1441
That’s great news!
Have fun with MobiFlight!!!
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2019-09-28 07:16
icon