MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
herly
Posts: 66
Dear all,
I just turn my homecockpit after certain time. Recently I have a problem on arsuino no. 4, this arduino is used for flaps gauge, brake pressure gauge, landing gear switch, etc. When the sim running everything also run properly. But after 3 to 5 minutes, the arduino no 4 not function. I have tried to empty memory and reupload the function, then its run again. After 3 minutes the arduio no 4 , again not function again.
I became Frustration, once I reupload there is a message uploas finished error. But if I empty the arduino and reupload, again its functiom.

Can sombody help me please.
Thank you.
2019-05-03 17:04
Avatar
StephanHo
From: EDDG, Germany
Posts: 1404
Supporter
Hi herly,

did you try a new MEGA or allways the old one?

If possible take a new one and try it again. If the new one works your old one has a malfunction. That may happen and is no error in itself.
Did you check your voltage supply while you have stepper or servos installed? Perhaps the power supply has a malfunction or if you did not have an external power supply check in every case the voltage. An Arduino Mega or a USB-interface can only drive 500mA totaly.

Standard check should always be voltage, current (external/internal), restmode and in operation.

Please report.
Grüße,
Stephan
2019-05-03 17:45
Avatar
herly
Posts: 66
Hi Stephane,

Thanks lot for the suggestion. I will try it and inform the result...

Warm regards,
2019-05-04 00:23
Avatar
herly
Posts: 66
Hello Stephan,

Finally I disconnect the brake pressure gauge and everything run smoothly...

It means 1 arduino should not be connected with 2 steppers, or it must be added with additional power.

Have a nice weekend..and thank you
2019-05-04 05:57
Avatar
StephanHo
From: EDDG, Germany
Posts: 1404
Supporter
Hi herly,

note, that a stepper needs in hibernation nealry 180-200mA. If you use 2... you can calculate. The MEGA itself needs also current and if the steppers are both running, the voltage shoult collapse.
Simply take an external power supply for the steppers.
Grüße,
Stephan
2019-05-04 16:22
icon