MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

Go to page 1Go to page 112Go to page 3Go to page 2
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3038
Supporter
Hi Again

Thank you for the files.... Mail arrived !

My first results:

1. Your Information was not complete. So my first "picture" of the situation was wrong ! ( Sorry for my firstly wrong recommendations)
You said you have 11 Buttons for the Mode.... Also one Encoder Button and the Encoder ( And i already think about the Swap Button) . But you not tell me that the same Board also Include lots of more buttons for other things like AP and GPS.
So basicly i think about maby 15-18 Pins in use.... But Your Config got 52 Pins in use... (46x Button 3x Encoder)
THIS is a complete different Situation !! (Whatever its within the official Limits)


2. Your Config looks "good" whatever as i said its extreamly to much complex and difficult. With better IF Conditions and some other logics you can tide up the Config a lot.
You also mix up different Input Types in a not usefull way.... May you just "test" something.... But in Finaly Project this should be systematic and not confuse ;)
(We can talk after we solve the main technical problem to make your config more usefull if you like !)


3. The Main Problem !

Here i can reproduce your first Step. I Not have a Board with 46 Buttons and 3 Encoders.... So i just test quickly the Costom Offset Inputs (66C0 and follow)" . I can confirm in first Testrun your result.
Would be interesting if this situation occure also in other Issues.... maby you can Confirm if all other buttons work.... OR If additional to the Custom Offset Inputs some others ( Like the COM Reciver Buttons, AP Buttons, GPS Buttons e.g). also NOT working ! ( I think so.... Not tested in case of not have so many buttons here a.t.m. )

iconJabezlr:


I ran the test 10 times (Stopping, then uploading the config, then Running again) and here are the results I got. The numbers indicate working inputs (numbered from 1-11)
- Test 1: 3,10


I Not make 10 Runs.... Only the First... But i can CONFIRM .... Only Input 3 and 10 Work. All Other let the LED on MEGA Blink.... But no action is detect by Mobiflight !

*****************
Solution:
This Problem need more investigation !

If you like you can do a simple test youreself ..... (Much faster as my jumperwire testboard here)

- Rework your Mfmc File for testing ..... Delete the last TWO Devices ( GPS OBS and GPS Message)
Upload the new List to the Board .... Restart Board and Mobiflight.... And now test it (All Inputs !!)

Please report results !
Thanks !
[Last edited by pizman82, 2019-04-05 03:09]
Good Luck !
2019-04-05 03:02
Avatar
Jabezlr
Posts: 10
Hi,

Thanks for the feedback.

Currently also have a breadboard and pins to test. However, was able to manage easily.

I did the following:
- Remove the last two line GPS OBS and GPS Message
- Closed Mobiflight and also restarted My Mega.
- Tested each pin which gave me the following results:
2 SPD Ok
3 HDG Ok
4 ALT Ok
5 APR Ok
6 NAV1 Ok
7 ATT Ok
8 LOC Ok
9 F/D Ok
10 MACH Ok
11 A/T Ok
12 TOGA Ok
13 W/L Ok
14 Y/D Ok
15 B/C NOK
16 MASTER Ok
17 NAV/GPS Ok
18 SELECT SPD NOK
19 SELECT HDG NOK
20 SELECT COURSE Ok
21 SELECT ALT NOK
22 SELECT V/S NOK
23 ADJUST Ok
24 ADJUST Ok
25 RESOLUTION NOK
26 COM1 Ok
27 COM2 Ok
28 BOTH NOK
29 NAV1 Ok
30 NAV2 Ok
31 MKR Ok
32 DME Ok
33 ADF Ok
34 SELECT COM1 NOK
35 SELECT COM2 NOK
36 SELECT NAV1 NOK
37 SELECT NAV2 NOK
38 SELECT ADF NOK
39 SELECT IDE NOK
40 ADJUST RADIOS Ok
41 ADJUST RADIOS Ok
42 RESOLUTION NOK
43 DME Ok
44 ACTIVE/STANDBY NOK
45 GPS Range No inputs
46 GPS Range No inputs
47 GPS Direct-To WPT No inputs
48 GPS Menu No inputs
49 GPS Clear No inputs
50 GPS Enter No inputs
51 GPS Nearest No inputs
52 GPS OBS Removed
53 GPS Message Removed
2019-04-05 21:51
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3038
Supporter
Bad.... I hoped this already solve the Problem.

Apollogy for your trouble..... But positive factor is.... NOW we have a clear Config that can reproduce the whole problematic.
I will send this Configs to Sebastian and Stephan for further testings.
I´m optimistic we can NOW see the issue ( That is also occure for lots of other people in other situations like long file names and so on)

Bad news.... i think this will take a while. Sebastian is verry bussy at the moment and not work on Mobiflight that time.
If you need fast solution then i recommend to reduce number of devices "extremely". Maby your system work if you just use 30-40 Devices per board (or less) . Simply Remove 1-2 Devices and test ... remove another 1-2 and test ..... aslong you got a working system..... Then build the romoved stuff on the next board.
AGAIN: This is not the solution.... This is just you can work until we finaly fix this problem and Mobiflight will work OK again.

Thank you.

PS. Maby we will add you to our workgroup in the Email Header. I Hope its ok if you do maby a final test of a BETA Version of Mobiflight to confirm bug is gone ! So please BACKUP the Files on your computer to test then the SAME Hardwaresituation like at them moment !
Good Luck !
2019-04-05 22:23
Avatar
Jabezlr
Posts: 10
Good morning,

A bit disappointing, but nevertheless, hope that Sebastian and Stephen will have some time at some stage to have a look and see what can be done.

Is there maybe a previous version available that I can also test or do you think this issue is also present on all older versions. It seems I can only download the latest version.

I think the first time I picked up some issues was above pin 30, I will thus limit it to around that number for a start.

I also intend to continue the development of my simulator and build small packages (less than 30 pins or so and create seperate mcc and mfmc file for each). I suppose that, once the bug has been resolved, I will be able to edit and combine the mfmc and mcc files in a text editor to be able to use all 51 available pins and use the minimum amount of Arduinos. I had a look at both files and it seems simple enough but please let me know if this would work.

I will gladly assist with testing of a BETA version - just let me know.

With regard to your earlier remark:
iconQuote:

2. Your Config looks "good" whatever as i said its extreamly to much complex and difficult. With better IF Conditions and some other logics you can tide up the Config a lot.
You also mix up different Input Types in a not usefull way.... May you just "test" something.... But in Finaly Project this should be systematic and not confuse ;)
(We can talk after we solve the main technical problem to make your config more usefull if you like !)



I have reduced my Preconditions already from 13 to 4.
Please let me know what other suggestions you have to simplify my config. Would like to implement these ASAP.
2019-04-06 08:55
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3038
Supporter
Hi Again!

About Older Versions.
You can download all Versions if you know the correct "Number" .... https://www.mobiflight.com/de/download.html
In the linked page you see all the Version History with there syntax like "7.5.2"

If you like to test for example Version 7.4.0 then you just must "rework" the current Download Link !
At the moment this is .... https://www.mobiflight.com/tl_files/download/releases/MobiFlightConnector-7.5.2.exe
Simply chage this in the Adress field of your Browser (firefox e.g.) into ....
https://www.mobiflight.com/tl_files/download/releases/MobiFlightConnector-7.4.0.exe
Then you can download the older Version . ( Not try out but i think most of the old files (maby all) still exist on the server !

NOTE: Mobiflight just see if Firmware is out of Date..... But i think it not see if Firmware is "to new" . Its recommend to Delete the Boards (EEPROM CLEAR SKETCH) before you use a older Version.... Cause you need the Firmware of that old Connector version that was correct.... The new one from 7.5.2 will occure in problems.
Also note that in older Versions some Bugs was not already fixed.... So check out the "Fixed History" what features are not build already when you use a older version !

*******
About the Re-Edit with Text Editor.
I Recommend to work here with a scripting Editor instead of a basic text programm.... Use for example "Notepad++" (Freeware) . With a professional tool you can see more efficient code parts (Colored with tabs) .
Basicly your right. Thats possible and easy.... But you should have basic knowledge to understand the "syntax" . If you miss a line or copy it to wrong position the file is "broke"
So do a BackUp before you edit this manualy.

*******
About simplify your configs.
For example your Preconditions in some configs got unless lines .... You need in Fine/Coarse Encoders 2 Lines with OR to define the 0/2 or 1/3 Situation.... This can be done with one line normaly.... Try out to say Precondition " Config Precondition - Comms Push ...." = and write in value field 0||2 the || symbols are syntax for OR. So this ONE Line should do the same like your two lines ( Not tested but normaly this should work)
If you do that and you not longer need TWO Preconditions here for that then you also not need a duplicate line for the " Com Mode Precondition" ( At the moment you use same line in front and again on end to prevent a issue in the AND/OR logic of Mobiflight.
If only 2 Preconditions are used then you can also save this additional line, too.
( Sorry for bad explanetation.... This must be showed via Email or by talk personaly.... then you better understand)



Another example is your Setting for the "Encoder Button of Radio"
You say ... if($=0,1,if($=1,2,if($=2,3,if($=3,0,0)))) .... More easy with same result is .... if($=3,0,$+1)


As i said... Your config is not wrong... You just make unless things.


Wish you a nice weekend !
Good Luck !
2019-04-06 15:23
Avatar
Jabezlr
Posts: 10
Good afternoon,

Thanks for the feedback on how to check old versions. I will go through the change history and then select the most suitable one.

I am in process to populate my boards and have limited the buttons and decoders to less then 28 pins and had no issues so far. I still need to see at what point the buttons and encoders become erratic and will let you know once I have an answer on that.

I am familiar with Notepad ++ and will use it to edit my config files once ready.

I also saw something posted in February in the forum that I will try - using shorter names for my buttons and encoders. Will let you know if this has any effect.

I suppose normal C++ operators (&& and ||) can be used. Makes sense - will try and if I don't come right I will let you know.

Thanks
2019-04-08 16:58
Avatar
Jabezlr
Posts: 10
Further feedback and progress:

- I renamed all my buttons and gave it short names. I used the following naming convention for the buttons and kept away from the long names I had previously:
- For buttons 3 digits used - digit 1 indicating the Mega no. next 2 indicating the pin no. e.g. 102.
- For encoders 5 digits used - digit 1 indicating the Mega no. next 4 indicating the pins used e.g. 24546.

Preliminary tested with the following:
Mega 1 : 52 pins used (46 buttons, 3 encoders)
Mega 2: 51 pins used ( 45 buttons, 3 encoders)
Mega 3: 33 pins used, all buttons

Tested and all the above working (at least for now) :thumbup: :thumbup:
2019-04-11 13:34
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3038
Supporter
THANKS

I´m happy to get the feedback but i´m sad it sounds like this.

So we have a "bigger" issue in the EEPROM Logic.
If i read the Script then the "Names" can be 14 diggits long.... Without Problems.
BUT In Real the number is MUCH MORE shorter ( Whatever it isn´t logical)

I Hope Seb can find the problem finaly much faster now. I will reply if i get new informations.
Good Luck !
2019-04-13 22:35
Avatar
Leta
Posts: 2
Hi all!
I'm new on this forum and this is my first post.

I am building autopilot and EFIS for B737 (and mayby something more) but I have similar problem. In my project I have 7seg displays (3 pins), 6 encoders (12 pins), 8 led (8 pins), 9 buttons (9 pins) and 7 triggers as buttons (7 pins) and everything works perfectly. All together used 39 pins, so there are 13 pins to use in my MEGA 2560. But when I add 1 button more, one of encoders stopped working (last in config). I'm not reach the limits of devices so I'm confused why it not works like it should? Is there any way to use this 13 pins as next buttons?
I use MF 7.5.2.
2019-07-18 18:15
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3038
Supporter
Hi

Apollogy for that !
I report that thematic to Sebastian but there is no progress at the moment. I don´t know if he work on that a.t.m.

My personal experience show me that the problem is located in the device names.
I don´t understand WHERE the Problem is directly located....
Maby it is the Length of a specific Device.... OR it is the sum of all Device names .... Or it is a strange logic like only XX Devices can have a name longer as yy Numbers.
As i said in other topics i try to experiment a bit but i found no logical indicater WHEN the Problem occure exactly.
BUT
In a "extreme" workaround it wa always possible to solve the problems ( if i remeber right in 100% of situations) .... Simply reduce device names extremly !
So if your LED on Pin 12 is named for example "Autopilot_Altitude-Hold LED" then rename it to "A1" for example.

My rules are simple.
1. NOT use Signs So Only A-Z and 0-9 is recommend .... Also no ÄÖÜäöü
2. NOT use Space Signs ..... So two words like "AP OFF" should not include the SPACE and from Step 1 also no "Sign like "-_:.;," ........... use simply use "apOFF"
3. Use Device names as short as possible..... For testing i use A01 to A52 and it work fine.

I wrote it multiple times.... I Personaly recommend a System with a "Number-Char" system like A11B22C33 . Every Number or Char give a information .... Like Number of Arduino, Number of Pin, Typ of Device , In or Output, Number of used Pins on this device, Position in cockpit and so on.
With this logic you create device names with a maximum of 5-8 Chars with no signs and no spaces.

***************
Summary....
I know the basic Problem should be fixed.... But aslong Sebastian do this we need to help ourself.... And the massive reduce of Length and not using Symbols is the most profitable way, i think.
Good Luck !
2019-07-18 23:11
Avatar
Leta
Posts: 2
Big thanks! I just cut all devices names as you said and everything works great! All 52 pins. Now I have to buy new MEGA for next works.
2019-07-19 15:37
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3038
Supporter
REFRESH !!!!
Currently Sebastian is back in buisness and work on some older Bugs ( also this one) .

I can proudly report HE could already solve a lot if issues and we are hopefull we can also solve THIS Problem. ( Looking forward for new release.... It will be fantastic !!)


While research in my Email Folder i found the Old File from "Jabezir" he send me. We will check this next couple of days if new Mobiflight Beta branch already solve the Problem.

REQUEST:


If a User is here ( That reported that Problem in the past and temporary solve it with my recommend "short as possible" Logic ) WE need YOUR Help !

Do you have a Backup History of that problematic files ?
We would need: The Old file that have the problem.... AND if Possible the reworked "shortname" File with same devices that finaly solve the problem!
So we can simply compare both files in the new Version to check functionality and see the sppecific issue spot.

Please send the Files to my Email.... pizman@freenet.de If possible with a short message what devices was broke and if it work after reduce length.

Thank You !!
Good Luck !
2019-08-14 21:48
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1441
Good news! I think I was able to fix the problem and I will soon release a new version of MobiFlight.
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2019-09-08 07:06
Go to page 1Go to page 112Go to page 3Go to page 2