MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
Skino
From: Osterwieck, Germany
Posts: 18
Ich versuche, die Mobi Firmware auf einen Uno zu laden und bekomme eine Fehlermeldung. der Connector ist auf 7.4.0, also aktuell.



Das Problem ist wohl, das der Connector den Arduino als Mega identifiziert hat, es aber definitiv ein Uno R3 ist.
Loging auf Debug Level ist aktiviert aber wo steht die Log-Datei? Ich finde sie nicht.
Und wie kann ich das Mega/Uno Problem lösen?
Hier ist auf wenn auf ist.
Jetzt ist zu.
2018-04-30 18:56
Avatar
StephanHo
From: EDDG, Germany
Posts: 1525
Supporter
Hi Skino,

das Problem läßt sich ganz einfach lösen: benutze einen MEGA 2560 R3

Grund: alle anderen Board werden von Mobiflight mittlerweile nicht mehr supportet.

Das mag für den einen oder anderen bedauerlich sein, ist aber momentan Fakt. Der UNO war auch, meines Wissens nach, nur experimentell.

Das Sebastian im Grunde für jedes Board eine unterschiedlich Firmware hätte schreiben müssen, wurden alle bis auf den MEGA eingestellt.

Ein chinesischer MEGA-Clone kostet momentan so um die 10 Euro, hat wesentlich mehr Anschlußmöglichkeiten (40 LEDs oder 50 Buttons oder Kombinationen davon).
Das ist vielleicht für dich momentan nicht zufriedenstellend, führt aber dazu, daß mit der vorhandenen Energie nur noch eine Firmware gewartet werden muß. Das birgt erhebliche Vorteile, da Mobiflight quasi eine One-man-show ist und Sebastian nebenbei noch Frau und Kinder ernähren muß.

Meine Empfehlung: steige auf den MEGA um. Danke für dein Verständnis
Grüße,
Stephan
2018-04-30 19:33
Avatar
Skino
From: Osterwieck, Germany
Posts: 18
Ok, dann schreibe ich weiterhin meine eigene Software.
Danke für die Antwort. :)
Hier ist auf wenn auf ist.
Jetzt ist zu.
2018-04-30 20:03
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3522
Supporter
Hey Skino altes Haus !

War die Tage nicht Online.... Deshalb erst jetzt.

Wir hatten damals das Problem das mit dem UNO Support ein BUG entstand weil einige UNO Kennungen auch vom Mega verwendet wurden.
"Damals" erkannte MF falscherweise die Megas als UNOs....
Da 98% der User Mega verwenden hat Sebastian das umgestellt.... Sozusagen das geringere Übel das jetzt die paar UNO User die Kacke haben.

Du kannst mit "bootloader" oder anderen Tools einfach die Firmware ( im Mobiflight Ordner) selber manuell aufspielen und so deinen UNO nutzen.
Bedenke aber das dort nicht alles wirklich klappt und kein Support seitens Sebastian mehr stattfindet.

Meine Empfehlung auch.... Wenn Mobiflight, dann MEGA ! Aber ein Programmierer wie du wird das auch mit den UNO und MF schaffen.

Liebe grüße an den WauWau !
Good Luck !
2018-05-09 10:50
icon