MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
AUA421
Posts: 89
1.) Autopilot funktioniert bestens
( via Laptop)
Aber nicht
2.) MF an Stand PC:

-Wenn ich MF starte ( es geht nur jeweils Neuinstallation der RAR Datei mit Programm "7"), find et DER pc einmal den Arduino,dann wieder nicht. Unbekannter Name wird angezeigt.

Wenn manches Mal der richtige Arduino gefunden wird, geht das Zuweisen eine Zeitlang gut, aber plötzlich mag die Maschine nicht mehr-----(oder mich! )---- und aus "M-èģa" wird "unbekanntesGerät" und alles war vergeblich, weil eine Eingabe nicht mehr möglich ist
Virenprogramm habe ich auf c nicht. Nur altes Kaspersky - abgelaufen! - auf e.
Firmware läßt sich auch nicht aufspielen -"? :nciht erfolgreich"
Was köñte ich machen, damit arduino erkannt bleibt /seinen Namen behält?

LG

Aua421
2018-04-18 20:34
Avatar
StephanHo
From: EDDG, Germany
Posts: 1538
Supporter
Ist die Arduino IDE in Mobflight korrekt eingetragen?

Normalerweise ist MF keine RAR-Datei. Allenfalls eine geziippte ausführbare .EXE. RAR habe ich in dem Zusammenhang noch nicht gesehen. Geh mal hier oben auf Mobiflight, dann kommst du zur Homepage und machst dort den Download der .EXE

Was auch helfen könnte, wäre ein Sketch aus der Arduino-IDE. Dort unter Datei auf Beispiele gehen,Menü klappt aus, auf EEPROM gehen, Menü klappt aus und EEPRO_CLEAR wählen, kompilieren und auf dein MF-Board hochladen. Danach ist dieses Board MF-technisch doof, also gelöscht. Es ist nun wieder für normale Arduino-Aufgaben bereit.

Du verläßt die IDE, rufst MF auf und lädst die aktuelle Firmaware wieder hoch. Nachdem das mit OK quittiert wurde, die Device-Datei (mmfc) und danach die Config-Datei (.mcc) wieder reinladen. Das Hochladen in den MEGA nicht vergessen, MEGA manuell resetten (roter Button). Nun sollte alles wieder laufen.
Grüße,
Stephan
2018-04-19 10:52
Avatar
AUA421
Posts: 89
Hallo!

Es scheint zu funktionieren.
Danke!

Aua421
2018-04-20 20:28
icon