MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
rscagliera
Posts: 1
Hi guys!

i Started the application and select the options bellow:

1) Extras -> Settings -> Mobiflight Modules -> Configured Modules.

The error showed when clicked to Add new Device.

The Log:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at MobiFlight.SettingsDialog.mfModulesTreeView_AfterSelect(Object sender, TreeViewEventArgs e)
at System.Windows.Forms.TreeView.OnAfterSelect(TreeViewEventArgs e)
at System.Windows.Forms.TreeView.TvnSelected(NMTREEVIEW* nmtv)
at System.Windows.Forms.TreeView.WmNotify(Message& m)
at System.Windows.Forms.TreeView.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1026 (RTMGDR.030319-1000)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
MFConnector
Assembly Version: 6.0.2.0
Win32 Version: 6.0.2
CodeBase: file:///E:/FLIGHT/MobiFlight-Arduino/MFConnector.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1032 built by: RTMGDR
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1001 built by: RTMGDR
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1026 built by: RTMGDR
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Data
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.237 (RTMGDR.030319-2300)
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.233 built by: RTMGDR
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1026 built by: RTMGDR
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Numerics
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1 built by: RTMRel
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1015 (RTMGDR.030319-1000)
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
FSUIPCClient
Assembly Version: 2.0.4008.2
Win32 Version: 2.0.4008.2
CodeBase: file:///E:/FLIGHT/MobiFlight-Arduino/FSUIPCClient.DLL
----------------------------------------
ArcazeHid
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///E:/FLIGHT/MobiFlight-Arduino/ArcazeHid.DLL
----------------------------------------
s3ia2ozv
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1026 built by: RTMGDR
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
AutoUpdater.NET
Assembly Version: 1.3.1.0
Win32 Version: 1.3.1.0
CodeBase: file:///E:/FLIGHT/MobiFlight-Arduino/AutoUpdater.NET.DLL
----------------------------------------
Microsoft.mshtml
Assembly Version: 7.0.3300.0
Win32 Version: 7.0.3300.0
CodeBase: file:///C:/WINDOWS/assembly/GAC/Microsoft.mshtml/7.0.3300.0__b03f5f7f11d50a3a/Microsoft.mshtml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Regards,
Reinaldo, From Brazil.
2015-05-14 12:07
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1441
ok, I will try to reproduce the error. Thanks for the hint, I'll let you know once it is fixed.
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2015-05-26 08:04
Avatar
hyamesto
Posts: 6
Same error here ......, but when click in "none" (see next...)

Using Mega 2560 R3.
Unrecognized. ("none" in Extras - Settings - Mobiflight Modules).

Mega 2560 R3 in COM 3, with
USB\Vid_2341&Pid_0042&Rev_0001

Card working good with arduino ide and example sketches.


Regards.
Horacio, from Argentina.
[Last edited by hyamesto, 2015-06-10 21:50]
2015-06-10 05:21
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1441
I can reproduce the problem easily on my PC if no cards are attached. I will provide a fix.
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2015-07-05 19:34
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1441
Horacio,

I had a look at the code and your VID/PID-combo is already supported.
It is probable that MFConnector is still looking up all modules which can take some time.
So just wait a moment and open the settings dialog again.

Please tell me if it works for you.
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2015-07-10 18:02
Avatar
emulov
Posts: 1
Same error here too, when clicking on "none".

I also waited a long time, but always the same problem.

Arduino Mega 2560 R3:
USB\VID_2A03&PID_0042&REV_0001
USB\VID_2A03&PID_0042

Hoping for a solution!

Best regards,
Isak
2015-07-11 22:57
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1441
Hi Isak

I am going to release a fix for this soon.
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2015-07-11 23:41
Avatar
hyamesto
Posts: 6
Same as Isak, Mega not reconigzed, waited 15 minutes, click on "none in "extras","settings" ,tab Mobiflight Modules, and same error. Waiting for fix...
Regards.
Horacio.
2015-07-14 13:12
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1441
MobiFlight needs only several seconds to enumerate everything. not minutes :)
You'll get the update soon.
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2015-07-14 19:38
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1441
iconrscagliera:

Hi guys!

i Started the application and select the options bellow:

1) Extras -> Settings -> Mobiflight Modules -> Configured Modules.

The error showed when clicked to Add new Device.

The Log:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at MobiFlight.SettingsDialog.mfModulesTreeView_AfterSelect(Object sender, TreeViewEventArgs e)
at System.Windows.Forms.TreeView.OnAfterSelect(TreeViewEventArgs e)
at System.Windows.Forms.TreeView.TvnSelected(NMTREEVIEW* nmtv)
at System.Windows.Forms.TreeView.WmNotify(Message& m)
at System.Windows.Forms.TreeView.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
[...]

Regards,
Reinaldo, From Brazil.



This should be fixed in the latest release 6.1.0
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2015-08-17 11:25
icon