MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
bob755
Posts: 20
Hello,
I reallly like Mobiflight and I'm progressing quite well. I have the 7 sement displays working but I have a problem with the encoders. I searched on the forum but didn't find a solution. (At least not in english!)

I've configured the encoder to change the PMDG altitude using the event 70022 and the mouse wheel parameters 16384 and 8192.

The altitude increases when I turn the encoder right and it decreases when I turn the encoder to the left so that proves that the event and parameters are correct.
The problem is that it changes the altitude value by anything between 2 and 5 each step. I've tried changing the encoder type parameter but that makes no difference.

I know I'm using the ky-40 encoder which is not recommended for Mobiflight but it appears that some people have successfully used this type of encoder.

Could the ky-40 be the problem?
2018-08-24 15:38
Avatar
bob755
Posts: 20
For some reason, Restarting FSX and Mobiflight has solved the issue and the encoder is working correctly.
2018-08-24 16:35
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 5571
Supporter
Hi. Basicly a Restart is mostly the solution.

I don´t know what you do exactly in this situation..... But for example after a Firmware Update a Restart is high recommend.
Also after installing new devices.

In the past i see that without restart some devices send multiple Commands whatever they are used only one time.

This happens not on every situation but sometimes.....

So i decide myself to make a Reset of Arduino and Mobiflight ALWAYS after i change something on the Arduino (Firmware /Device)
Good Luck !
2018-08-25 10:37
icon