MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
StephanHo
From: EDDG, Germany
Posts: 1525
Supporter
Hi zusammen,

heute ist mir beim Logging von MF aufgefallen, daß es bei Schaltern zu ominösen Meldungen kommt.

Zunächst meldet MF, daß eine Konfiguration für die Taste X gefunden wurde.
Dann wird die Konfiguration für ON PRESS ausgeführt, sodann wieder die gleiche Config für Taste X gefunden, diesmal wird aber ON RELEASE angegeben. Bei ON RELEASE ist aber gar nichts eingetragen.

21.04.2018 20:09:40(558): Executing OnRelease: AP PRST SW@SN-b59-4d4
21.04.2018 20:09:40(548): Config found for button: AP PRST SW@SN-b59-4d4
21.04.2018 20:09:40(396): Executing OnPress: AP PRST SW@SN-b59-4d4
21.04.2018 20:09:40(385): Config found for button: AP PRST SW@SN-b59-4d4

Ist das eine Standardvorgabe oder ein Fehler? Auf jeden Fall irritierend.
Grüße,
Stephan
2018-04-21 20:08
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3527
Supporter
Ist das noch aktuell Stephan oder war das eine Eintagsfliege ?
Good Luck !
2018-05-23 08:10
Avatar
StephanHo
From: EDDG, Germany
Posts: 1525
Supporter
Ich prüfe das mal durch und melde mich wieder
Grüße,
Stephan
2018-05-23 13:06
Avatar
StephanHo
From: EDDG, Germany
Posts: 1525
Supporter
Scheint ein Dauerzustand zu sein.

Logging-Meldung:

23.05.2018 18:35:27(543): Executing OnRelease: AP PRST SW@SN-b59-4d4
23.05.2018 18:35:27(534): Config found for button: AP PRST SW@SN-b59-4d4
23.05.2018 18:35:27(366): Executing OnPress: AP PRST SW@SN-b59-4d4
23.05.2018 18:35:27(357): Config found for button: AP PRST SW@SN-b59-4d4


Dazugehörige Config:

</config>
<config guid="6fa09381-4a64-473e-be11-da85e8c8679e">
<active>true</active>
<description>AT PRST SW</description>
<settings msdata:InstanceType="MobiFlight.InputConfigItem, MFConnector, Version=7.4.0.0, Culture=neutral, PublicKeyToken=null" serial="FSX 01/ SN-b59-4d4" name="AT PRST SW" type="Button" xmlns:msdata="urn:schemas-microsoft-com:xml-msdata">
<button>
<onPress type="EventIdInputAction" eventId="69972" param="536870912" />
<onRelease />
</button>
<preconditions />
</settings>
</config>

Somit ist es noch aktuel.

Habe allerdings nicht probiert, was passiert, wenn ich tatsächlich eine EventID auf ON RELEASE lege...
Grüße,
Stephan
2018-05-23 18:39
icon