MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
Kenneth
Posts: 5
Hello again,

First of and once again thank you for your initiative and effort.

I have had some problems after I added preconditions. Now MobiFlight wont start. After pressing the icon it will light up the led's and then go dark as it has always done when starting. After this point it crashes. I ended up wiping the board with the arduino software, downloaded and started a fresh version of MobiFlight and hey presto, it works. Well that is until I close down MobiFlight and start it up again. The problem is back. So to get it working I need to wipe the board again, upload the Mobiflight firmware and open the saved config.


Any thoughts or experience?



Best regards;

Kenneth Brander



On a side note, MobiFlight registers a Nano as a mega.. It's a Nano that is located on COM12

11.04.2016 18:02:33: Something went wrong when flashing with command
"E:\Arduino\hardware\tools\avr\bin\avrdude" -C"E:\Arduino\hardware\tools\avr\etc\avrdude.conf" -patmega2560 -cwiring -P\\.\COM12 -b115200 -D -Uflash:w:"E:\MobiFlightConnector-7.0.5\firmware\mobiflight_mega_1_4_1.hex":i



This is the error indicated by windows when it crashes..

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: mfconnector.exe
Problem Signature 02: 7.0.5.0
Problem Signature 03: 569a28fa
Problem Signature 04: MFConnector
Problem Signature 05: 7.0.5.0
Problem Signature 06: 569a28fa
Problem Signature 07: 37c
Problem Signature 08: 13e
Problem Signature 09: System.NullReferenceException
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1044
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
[Last edited by Kenneth, 2016-04-13 17:44]
2016-04-11 17:40
Avatar
pizman82
From: ETSI, Germany
Posts: 3732
Supporter
Hello Kenneth.

This sounds like a problem in youre Config itself. If theres a error in this config then Mobiflight always crash when starting cause this config is still used.
As you suscribe you can solve the crash by install a new software (OR with rename the issue mcc file) . after you load the file again you have to check the configs to find the error.... If you cleanup youre config and found the problem then the restart of mobiflight should worke without an error.

If the issue was in Firmware update meanwhile there is a new firmware. so that should be solved too.

Good Luck !
[Last edited by pizman82, 2017-01-12 08:02]
Good Luck !
2017-01-12 05:45
icon