MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

Posts: 7
Good day all!

Via the MobiFlight shop, I bought an already assembled, firmwared, and tested Arduino Pro Micro, which I received today. Unfortunately, when I connect it to my computer, the module is not recognized by MobiFlight (v9.6), and a red LED is turned on. The Pro Micro is only connected via USB (so no pins), but I would expect that it does not make a difference. I tried a couple of different USB cables, so that should not be the issue. It also does not show up in the Device Manager and I tried a couple of different USB ports.

When I connect my Arduino Mega, it immediately shows up in MobiFlight and it works without any issues.

Does anybody have any suggestions? Because I bought it fully prepared, I expected it to work immediately. Hope I don't have to reset the board :-/

I plan to use the board for creating an GTC570 (part of the Garmin G5000) for the Cessna Citation Longitude in MSFS :rolleyes: :rolleyes: :rolleyes:

Thanks in advance,
[Last edited by elha65, 2022-12-16 16:05]
2022-12-16 15:35
From: ETSI, Germany
Posts: 5979

For detailed informations/support our Discord is way better
... like a personal chat to give you the help you need !

Whatever.... I expect mostly this is a driver Problem.
I not know for now what board is currently in the shop .... If its a CH340 ( Mostly this is used) then you need Drivers for that.

NOTE: Older Megas ( not based on the CH340) work fine with just the drivers of the Arduino IDE. The CH340 will not and need this files.
Google for "CH340 Drivers" and simply download/install them.
Good Luck !
2022-12-28 18:19
Posts: 7
Hi Pizman82,
I missed your reply earlier, apologies about that. Meanwhile, I have been in touch with Sebastian and the issue is solved now.

It seemed that the USB cable I was using, is for charging only and not for data transfer. So out of four pins, my cable had only two pins wired. After I tried another USB cable it worked. By simple looking at the cable, it is not possible to identify if the cable can be used for data transfer.
The main difference I found, is that when you plug in the Arduino with the correct cable, you immediately see a couple of LEDs flash shortly, and the Arduino should also show up in the Device Manager in Windows.

Hope this is of help for others too.

2023-02-04 09:14