MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
djchema
From: Las Palmas de Gran Canaria, Spain
Posts: 4
Good afternoon.

I am configuring the FLT ALT and LAND ALT displays with the MAX7219 controller for the PMDG 737NGXu aircraft, P3DV5.1, on a Mega 2560 board.
They are connected in series with independent current of 5V.
The configuration I use is the following:

FLT ALT (Connector 1)
FSUIPC: Off set: 64E4 / int / Bytes 4
Display: Number of digits = 8 / Use Left Padding = set / Use display 4.5.6.7.8 = set
When I do the test, a number five appears in the last digit. If I change the value of Use display to three, a number three appears in the last digit and if I change the value of Use display to eight, a number eight appears in the last digit and so on.

LAND ALT (Connector 2)
FSUIPC: Off set: 64E8 / int / Bytes 4
Display: Number of digits = 8 / Use Left Padding = set / Use display 4.5.6.7.8 = set
In this case, if the selected digits appear and in the correct way.

When I'm on the plane, inside the simulator, the FLT ALT display does not show anything, and the LAND ALT display only shows a zero in the last display. When I want to select an altitude, Mobiflight detects the correct simulator values ​​but the displays don't work.

For more information, I have done tests with an independent and different arduino, and I have only connected a display and it keeps giving me the same problems.

I've been testing for two days :confused: and I don't know what else to do. If anyone can help me or give me ideas, I would be very grateful for the help.

I apologize for my English. I had to ask google translate for help :blush:
2021-05-15 22:02
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 5571
Supporter
Hi
icondjchema:


I am configuring the FLT ALT and LAND ALT displays with the MAX7219 controller for the PMDG 737NGXu aircraft, P3DV5.1, on a Mega 2560 board.

FLT ALT (Connector 1)
FSUIPC: Off set: 64E4 / int / Bytes 4

LAND ALT (Connector 2)
FSUIPC: Off set: 64E8 / int / Bytes 4



Wrong Offsets... For the NGX"u" there are new Offsets...... Check your Lists !
( I also thought the old ones should work already.... But maybe they remove them ! )

.......
iconQuote:

6C82 6 STR:6 AIR_DisplayFltAlt[6] Pressurization system FLT
ALT window, zero
terminated, can be blank
or show dashes or show
test pattern
6C88 6 STR:6 AIR_DisplayLandAlt[6] Pressurization system
LAND ALT window, zero
terminated, can be blank
or show dashes or show
test pattern




NOW these are STINGS..... But benefit is...: They include Lighttest and Battery Status already all in one !
Good Luck !
2021-05-15 22:33
Avatar
djchema
From: Las Palmas de Gran Canaria, Spain
Posts: 4
Thanks for quick answer to my question.
I have followed your instructions and it has been solved 50%. :-/
FLT ALT (Connector 1)
FSUIPC: Off set: 6C82 / String
Display: Number of digits = 8 / Use Left Padding = set / Use display 4.5.6.7.8 = set
The same thing that I explained in the first post continues to happen.

LAND ALT (Connector 2)
FSUIPC: Off set: 6C88 / String
Display: Number of digits = 8 / Use Left Padding = set / Use display 4.5.6.7.8 = set.
PERFECT. WORKS!!!. :) :) :) :) :) :) :)

I do not understand, why, the first module does not work, and the second connected after the first does work. :confused: :confused:

Any more ideas?
2021-05-15 23:45
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 5571
Supporter
Hi again.

Now we talk about a Electrical or Setting Issue Pretty sure.

Step 1:
Check the Mobiflight Configs ( In the Connector window)
BEHIND the configs you see 2 Collumns. FSUIPC Value and OUTPUT Value.
In Your case both should be the same in case we not use any Compare/Transforms.
So Check.... WHAT is shown in the Problematic Config in these Lines.
If There is written e.g. "8000" but on your Display is NOT the same number ..... THEN we have a electrical Problem or a basic Hardware Setting Issue !
This line simply say.... THATS the value MF send to the Display.... So it MUST show the same number or there is a hardware/setting Problem!


You can also simply confirm this.....
Change in the 2 Configs simply the DEVICE ..... ( Use the Display from the working Config in the non working Config and reversed.

Expected Result: Now the Display that former show LandAlt will now show FLT Alt Value..... The other Display is already "broke"


************************

If you can confirm this....

Possible issues:

1. Wrong Display selected in the Config. ( Not NUM1 or NUM2 )

2. Display ( chain) wrong defined in the Device Settings ( not NUM2)
EDIT: Thats the reason i think !! Please CONFIRM you use in the Device Settings for that Displaychain the correct "NUM2" setting !!!


3. Bad wire work. If a electrical Problem.... Try to swap the Displays... So the first get second and the secodn get first !
[Last edited by pizman82, 2021-05-16 02:13]
Good Luck !
2021-05-16 02:07
Avatar
oscarbcn78
Posts: 12
Hi,

I am trying to set up FLT ALT and LAND ALT in my overhead with MobiFlight and MAX7219 displays. According to PMDG the offsets seems to be 656C and 6572, string type, but it doesn't work. On the other hand, I can't find MSFS2020 Custom options. Could you help me?

Thank you so much!!
2022-08-05 10:40
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 5571
Supporter
Hi Oscar

Here we talk about different things. The old Topic talk about P3D .... You talk about FS2020!

1. Your right.
There is no Preset i think till now for the FS2020 PMDG. You can request for this in our Discord ( Sub Channel PMDG Workgroup)
Specially "Jaime Leon" is our Pro USer here. He own the PMDG and create most of the Presets himself.
Pretty sure he can dig the needed Variables for you and can include it in the HubHop Database!

2. FSUIPC Offsets.

The "656C Stuff" you talk about are FSUIPC Offsets. thats the way we handle it in the past for FSX and P3D.
FSUIPC remove this in the first time for FS2020 but they currently include it once again. As i know just experimental in a BETA Version.
Not in the Live Release. BUT It looks good and tests was sucessfull. Just some Offsets have maybe change. So you will need maybe a new list for this.

To test this:
1. Download and install the FSUIPC Beta Version (Link in the FSUIPC Support Forums .... Something like "FSUIPC-BETA include PMDG Support")
2. GEt sure your PMDG is Up To Date!
3. Enable the Data Broadcast in the PMDG Ini File

Then all the Outputs should work like in the past ! As i know Input (EventID) is not included in the first Beta Versions. But hopefulyl will come soon.
Good Luck !
2022-08-05 14:23
Avatar
oscarbcn78
Posts: 12
I solved it simply by installing the FSUIPC 7.3.8.b. Thank you!
2022-08-05 19:13
icon