MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
ifrpilot89
Posts: 8
I'm running X-Plane 11.55 with the latest version of MF and XPUIPC. I'm using a push/pull switch connected to my Arduino to act as my Carb Heat control of my vFlyeAir Piper Cherokee. I'm using the offset from XPUIPC of "08B2" which describes it as "Engine 1 Anti-Ice or Carb Heat switch (1=On)" in the XPUIPC Offsets 20140803.pdf and basically the same in the Mobiflight presets. In the DataRefTool plugin, searching on "carb" brings up 5 results. Commands of "sim/engines/carb_heat_on", "sim/engines/carb_heat_off" and "sim/engines/carb_heat_toggle". Mobiflight shows the values change to ones when pulled/on, and zeros when pushed/off, but no movement on screen or state change in the DataRefTools window. I've tried other free offsets, but with the same results. I've changed the function of the switch to control the Landing lights and/or the pitot heat and they work fine, so it's not the switch or the arduino. I've even added a command to the XPUIPC config file using different offsets, but still no joy. Any thoughts or help would really be appreciated.
Here is the code I tried in the xpuipc.cfg "Command 0x08B2 UNIT8 1 0 sim/engines/carb_heat_on _
1 1 sim/engines/carb_heat_on"

Thanks,
Steve
2022-04-23 00:05
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 5474
Supporter
Hi

If Possible please joind DISCORD.

there "Sam" is a User who have a lot of experience.
Also i can try to help.... But in case i not own Xplane we would need to make a shared Screen/Voice Seasson.
Then we can figure this out together.
Good Luck !
2022-04-23 01:02
icon