MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
LHA664
Posts: 1
Hallo an alle
Ich brauche Hilfe mit der Verbindung zwischen XPUIPC und MF.

Folgendes: Ich habe mir ein Panel mit den Autopilot und ND Funktionen sowie eine Konsole mit APU, Ext Lichter usw. Funktionen gebaut.
Die Taster/Schalter sind über Joystickcontroller Platinen direkt mit XP verknüpft und die Encoder für SPD, HDG, ALT, VS, BARO sind über zwei Arcaze Platinen mit dem SIM verknüpft.
Jedes Flugzeug was ich fliege hat sein eigenes Button Profil in XP und nicht vorhandene Commands werden über Fly with LUA erzeugt. Das funktioneirt soweit. Nun möchte ich den Satus der Funktionen über LED´s gesteuert von den Arcaze anzeigen lassen.
Die Verbindung zwischen MF Connector und Arcaze funktioniert da ich die LED´s im Config Wizard testen kann. Lade ich ein Flugzeug das ich mit XP Defaults Commands steuern kann wie z.B. Flysim Dash 8Q400 kann ich über das PreSets im Config Wizzard einige LED´s bei betätigen des jeweiligen Taster/Schalter ansteuern.
Soweit so gut. Jetzt kommt der Teil der nicht funktioniert.
Sobald ich aber das PreSet nicht nutzen kann, also im XPUIPC Custom Datarefs erzeugen muss läuft das nicht. Entweder mache ich bei der Erzeugung der Datarefs einen Fehler oder im Config Wizard.
Vielleicht könnt ihr mir ja weiter helfen

z.B. meine Programmierung für den FD der Zibo B738, wenn ich den dann als Muster auf alle anderen LED´s übertragen kann wäre das super.

Zeilen in der XPUIPCOffsets.cfg:
# FD
Dataref fdled laminar/B738/switches/autopilot/fd_ca int
Offset 0x6618 UINT8 1 r $fdled

Und die entsprechenden Zeilen aus meiner B737.mmc
<config guid="5934b121-349f-4248-a806-bfc191a39dfc">
<active>true</active>
<description>FD</description>
<settings msdata:InstanceType="MobiFlight.OutputConfigItem, MFConnector, Version=8.0.2.0, Culture=neutral, PublicKeyToken=null" xmlns:msdata="urn:schemas-microsoft-com:xml-msdata">
<source type="FSUIPC" offset="0x6618" offsetType="Integer" size="1" mask="0x0004" bcdMode="False" />
<comparison active="True" value="4" operand="=" ifValue="1" elseValue="0" />
<display type="Pin" serial="Front Panel/ 001082800000" trigger="normal" pin="B11" pinBrightness="255" />
<interpolation active="False">
<value x="0" y="0" />
<value x="1024" y="1024" />
</interpolation>
<preconditions />
<transformation active="False" expression="$" substrStart="0" substrEnd="7" />
<configrefs>
<configref active="False" ref="4a5de2ed-ebd8-4db1-9513-1046c708009c" placeholder="B" />
<configref active="False" ref="98d86611-17ce-4960-8f5f-02e4ed3dfa2a" placeholder="A" />
<configref active="False" ref="a419e520-a8e4-46da-b697-8352c02e9c95" placeholder="@" />
<configref active="False" ref="0d69d662-a21a-4c9e-90d1-f1d3eb0f4b74" placeholder="?" />
<configref active="False" ref="c18002ff-2849-4159-b03e-0776f189fc14" placeholder="§" />
<configref active="False" ref="79a6dc68-80ac-4ae3-a5e0-c1730e0875b8" placeholder="#" />
</configrefs>
</settings>
</config>

Hello everyone
I need help with the connection between XPUIPC and MF.

The following: I built a panel with the autopilot and ND functions as well as a console with APU, Ext lights etc. functions.
The buttons / switches are linked directly to XP via joystick controller boards and the encoders for SPD, HDG, ALT, VS, BARO are linked to the SIM via two Arcaze boards.
Every airplane I fly has its own button profile in XP and commands that are not available are generated via Fly with LUA. That works so far. Now I would like to display the status of the functions via LEDs controlled by the Arcaze.
The connection between the MF Connector and Arcaze works because I can test the LEDs in the Config Wizard. If I load an aircraft that I can control with XP Defaults Commands such as Flysim Dash 8Q400, I can control some LEDs via the PreSets in the Config Wizard when the respective button / switch is pressed.
So far so good. Now comes the part that doesn't work.
But as soon as I cannot use the PreSet, i.e. I have to generate custom Datarefs in the XPUIPC, it does not work. Either I make a mistake when generating the datarefs or in the Config Wizard.
Maybe you can help me out

Gruß LHA664
2021-06-05 16:12
Avatar
Banzai
From: France
Posts: 84
hello

the good dataref for FD captain led is " laminar/B738/autopilot/master_capt_status"
2021-06-05 20:10
icon