MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
peacefarm
Posts: 2
Hi all,

Thank you for allowing me to join your amazing community!

I'm wondering, has anyone has an success with encoders and their ability to spin quickly and the sim reacting to the fast movement? I've tried that "fast" assignments but haven't had any luck. I find myself having to spin encoders pretty slowly for the sim to recognize the input. If I spin it even at a medium rate, the HDG bug just doesn't move. Any help would be appreciated!

FYI: I'm using the traditional cheap Chinese encoders off Amazon. Would optical encoders help this matter or is a limitation of FSUIPC or other software?

Thanks!
2021-05-01 04:43
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 4554
Supporter
Hi

There was/is a Bug in the Encoder System!

Whatever "no respond" is normaly not a fact here. In case of the Bugs the Encoders miss "a lot" of detents and just execute a couple of them.
And also execute wrong directions ( e.g. a left whatever you turn right fast ).

Solution:

The Hotfix is done last week..... So it is NOT already included in the BETA Version ( And will not included to BETA for now in case we release a New Build 8.1.0 the next days )
Problem is solved..... Sebastian test Encoders for real with a Handdriller to simulate extremely fast turns..... No Missing detents or issues while his testings !


So..... Simply wait for next version.... ( Hopefully within the next Week)
If we not be able to release it in a acceptiable time...... Call me again. Then i ask Sebastian to provide another Beta to help you imidiatly!
Good Luck !
2021-05-01 07:07
Avatar
peacefarm
Posts: 2
Hi,

That is outstanding news! Thank you very much. :w00t:
2021-05-01 17:56
Avatar
Cotam
Posts: 16
It seems that the new version is here....But now, every encoders of my setup are triggering 2 detents per cycle while they are configured for 1 detent per cycle. So, if I turn my HDG encoder to 1 detent, I gain or loose 2 degrees...:scared:
2021-05-03 22:08
Avatar
Cotam
Posts: 16
Mmmh, anyway, I restarted MF and it seems ok now :blink:
2021-05-03 22:10
Avatar
jeff_d
Posts: 11
One trick I've been doing is firing up the Arduino IDE and checking the Serial output. This helps me debug issue between HW, FW and Software. It would be nice if MF had an option for turning on Serial spew in the log output would save time switching between the two.
2021-05-04 06:56
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 4554
Supporter
Normaly not needed.

Simply rule.

If you change something.... Whatever you create a new device like a LED, Update Firmware or Flash firmware for new....
If all is fine, then do nothing..... If there is a Issue simply RESTART the Mega and Mobiflight.

I know Sebastian tell me i should not official recommend this.... In case he like MF should work without Restarts.....
BUT
For myself.... I make a Restart EVERYTIME i add something new....
I also STOP and RUN Mobiflight if i change a Config Setting ( E.g. use another Formula or Value).....
And Finaly i SAVE and Restart MF Connector if i add a New Config Line, before i start working with it.

Reset take nearly no time... And mostly it solve problems already. Or in my situation.... I never have problems in case i made the Reset preventive everytime !
Good Luck !
2021-05-04 10:32
Avatar
jeff_d
Posts: 11
https://www.youtube.com/watch?v=nn2FB1P_Mn8
2021-05-04 19:14
icon