MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

Go to page 1Go to page 112Go to page 3Go to page 2
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1470
Ich vermute Du hast MobiFlight in ein neues Verzeichnis installiert. Dabei verliert MobiFlight die Einstellung welche Extension Module angeschlossen sind. Du musst in dem Fall in die Settings und dann da für das Arcaze die Extension Module nochmal definieren.

Kann es daran liegen?
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - MSFS2020, FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2020-09-15 19:08
Avatar
didi21at
Posts: 10
Hi!

Also die Einstellungen habe ich natürlich gemacht. Sowohl verwaiste Module, als auch das extension Modul "Leddriver2"
bei 7.8.3 ist links unten ein gelbes Warndreieck bei "Mudule" im Hauptfenster
bei 7.8.4, 7.9.0 und 7.10.0 erscheint beim Start das grüne Häkchen, alle Leds, die am Led driver hängen, leuchten auf. Die Arcazes werden erkannt, auch in den Einstelllungen.
Die Leds, die direkt am Arcaze hängen funtionieren, die am Led-driver nicht.

Soll ich Fotos schicken, damit das Problem vielleicht verständlich wird? Eventuell ein Video machen und auf youtube stellen?
2020-09-15 22:13
Avatar
Hano
Posts: 5
iconDocMoebiuz:

Ich vermute Du hast MobiFlight in ein neues Verzeichnis installiert. Dabei verliert MobiFlight die Einstellung welche Extension Module angeschlossen sind. Du musst in dem Fall in die Settings und dann da für das Arcaze die Extension Module nochmal definieren.

Kann es daran liegen?



Nein. Wie in meinem letzten Post bereits geschrieben lässt sich kein Extension Modul "definieren". Die Einstellung "LED Driver II" wird in den Settings nicht übernommen! Wenn ich die Settings ein zweites mal aufrufe steht dort wieder "Internallo" obwohl ich vorher "LED Driver II" eingestellt und mit OK bestätigt habe. Bei den neuen Versionen des MFC lässt sich nicht. anderes als "Internallo" für die Arcaze Module einstellen, bzw. speichern. Bei den älteren MFC-Versionen war das Speichern unterschiedicher Extension Module dagegen kein Problem.
2020-09-16 09:18
Avatar
didi21at
Posts: 10
Ich habe mal Videos gemacht, vielleicht hilft das!

Arcaze FC 3.7: funktioniert
https://youtu.be/GsrEZ7eX5GM

Mobiflight connector 7.8.2: funktioniert
https://youtu.be/mpH365pZoSg

Mobiflight connector 7.8.3: funktioniert nicht
https://youtu.be/fRU8nmR_0Zs

Mobiflight connector 7.8.4: funktioniert nicht. ebenso reagieren 7.9.0, 7.10.0
https://youtu.be/7OU-mmcLB1M
[Last edited by didi21at, 2020-09-16 15:31]
2020-09-16 15:21
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1470
Hallo! Danke für die Videos... das hilft ein bisschen... aber ich muss jetzt erst mal einen LED Driver und so bei mir finden. Ich kann es aktuell schwer reproduzieren.
Kannst Du mal bitte schauen ob es bei 7.8.3-4 hilft wenn du ein manuelles CheckUpdate triggerst?
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - MSFS2020, FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2020-09-16 21:14
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1470
iconHano:

iconDocMoebiuz:

Ich vermute Du hast MobiFlight in ein neues Verzeichnis installiert. Dabei verliert MobiFlight die Einstellung welche Extension Module angeschlossen sind. Du musst in dem Fall in die Settings und dann da für das Arcaze die Extension Module nochmal definieren.

Kann es daran liegen?



Nein. Wie in meinem letzten Post bereits geschrieben lässt sich kein Extension Modul "definieren". Die Einstellung "LED Driver II" wird in den Settings nicht übernommen! Wenn ich die Settings ein zweites mal aufrufe steht dort wieder "Internallo" obwohl ich vorher "LED Driver II" eingestellt und mit OK bestätigt habe. Bei den neuen Versionen des MFC lässt sich nicht. anderes als "Internallo" für die Arcaze Module einstellen, bzw. speichern. Bei den älteren MFC-Versionen war das Speichern unterschiedicher Extension Module dagegen kein Problem.


Also bei mir geht das. Denk dran dass Du auf das Arcaze klicken musst, bevor die Einstellung geladen wird.
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - MSFS2020, FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2020-09-16 21:17
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1470
I released 7.10.0.5 - I hope this fixes the issue. Please enable "BETA" releases in the "Settings" Menu to update to the latest BETA.
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - MSFS2020, FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2020-09-16 22:06
Avatar
didi21at
Posts: 10
It works!
Mit dem Beta-update ist das Problem behoben, 7.10.0.5 läuft problemlos!

Vielen Dank und großes Lob an den tollen Support und die Arbeit, die du dir/ ihr euch mit diesem Projekt macht!
2020-09-17 06:53
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1470
Super! Viel Spaß dann beim Bauen!
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - MSFS2020, FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2020-09-17 07:24
Avatar
Hano
Posts: 5
Werde es morgen auch ausprobieren. Gehe aber davon aus, dass es bei mir auch läuft. Super Arbeit. Vielen Dank. Würdest du uns noch verraten (für einen Laien verständlich :-) ) wo das Problem lag?

Gruß
Hano
2020-09-17 09:32
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1470
Bei der Umstrukturierung der Initialisierungslogik um den Startup von MobiFlight zu beschleunigen, ist die Arcaze Initialisierungslogik and den falschen Platz gerutscht. Sie kam zu spät. Das ist jetzt korrigiert und nun scheint es wieder wie vorher zu laufen.
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - MSFS2020, FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2020-09-17 13:35
Avatar
snooty83
Posts: 2
Hallo

Ich habe ebenfalls 2 LedDriver2 und 1 LedDriver3. Ich habe mit der 7.10.0 Probleme das alle LED leuchten. Daher wollte ich mal die erwähnte Version 7.10.0.5 Versuchen.
Kann ich irgendwo die Beta Version 7.10.0.5 Downloaden?
Ich habe mit der Aktuellen Beta Version 7.10.0.14 Probleme. Siehe unten. Ich bringe unter dieser Version keine LED zum Leuchten. Kann auch meine Acraze Module nicht zuordnen.

Danke

Gruss Dani



Informationen über das Aufrufen von JIT-Debuggen
anstelle dieses Dialogfelds finden Sie am Ende dieser Meldung.

************** Ausnahmetext **************
System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
bei MobiFlight.UI.Dialogs.SettingsDialog.okButton_Click(Object sender, EventArgs e)
bei System.Windows.Forms.Control.OnClick(EventArgs e)
bei System.Windows.Forms.Button.OnClick(EventArgs e)
bei System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
bei System.Windows.Forms.Control.WndProc(Message& m)
bei System.Windows.Forms.ButtonBase.WndProc(Message& m)
bei System.Windows.Forms.Button.WndProc(Message& m)
bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Geladene Assemblys **************
mscorlib
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4300.0 built by: NET48REL1LAST_C.
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll.
----------------------------------------
MFConnector
Assembly-Version: 7.10.0.14.
Win32-Version: 7.10.0.14.
CodeBase: file:///C:/Users/User/Documents/Flusi%20Programme/MobiFlightConnector/MFConnector.exe.
----------------------------------------
System.Windows.Forms
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4270.0 built by: NET48REL1LAST_C.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll.
----------------------------------------
System
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4300.0 built by: NET48REL1LAST_C.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll.
----------------------------------------
System.Drawing
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4084.0 built by: NET48REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll.
----------------------------------------
System.Configuration
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4190.0 built by: NET48REL1LAST_B.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll.
----------------------------------------
System.Core
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4300.0 built by: NET48REL1LAST_C.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll.
----------------------------------------
System.Xml
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4084.0 built by: NET48REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.
----------------------------------------
System.Data
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4270.0 built by: NET48REL1LAST_C.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll.
----------------------------------------
System.Windows.Forms.resources
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4084.0 built by: NET48REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms.resources/v4.0_4.0.0.0_de_b77a5c561934e089/System.Windows.Forms.resources.dll.
----------------------------------------
System.Numerics
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4084.0 built by: NET48REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll.
----------------------------------------
MFConnector.resources
Assembly-Version: 7.10.0.14.
Win32-Version: 7.10.0.14.
CodeBase: file:///C:/Users/User/Documents/Flusi%20Programme/MobiFlightConnector/de-DE/MFConnector.resources.DLL.
----------------------------------------
MFConnector.resources
Assembly-Version: 7.10.0.14.
Win32-Version: 7.10.0.14.
CodeBase: file:///C:/Users/User/Documents/Flusi%20Programme/MobiFlightConnector/de/MFConnector.resources.DLL.
----------------------------------------
Microsoft.FlightSimulator.SimConnect
Assembly-Version: 11.0.62651.3.
Win32-Version: .
CodeBase: file:///C:/Users/User/Documents/Flusi%20Programme/MobiFlightConnector/Microsoft.FlightSimulator.SimConnect.DLL.
----------------------------------------
AutoUpdater.NET
Assembly-Version: 1.6.0.0.
Win32-Version: 1.6.0.0.
CodeBase: file:///C:/Users/User/Documents/Flusi%20Programme/MobiFlightConnector/AutoUpdater.NET.DLL.
----------------------------------------
FSUIPCClient
Assembly-Version: 3.1.22.335.
Win32-Version: 3.1.22.335.
CodeBase: file:///C:/Users/User/Documents/Flusi%20Programme/MobiFlightConnector/FSUIPCClient.DLL.
----------------------------------------
Microsoft.GeneratedCode
Assembly-Version: 1.0.0.0.
Win32-Version: 4.8.4084.0 built by: NET48REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.
----------------------------------------
Microsoft.GeneratedCode
Assembly-Version: 1.0.0.0.
Win32-Version: 4.8.4084.0 built by: NET48REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.
----------------------------------------
System.resources
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4084.0 built by: NET48REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.resources/v4.0_4.0.0.0_de_b77a5c561934e089/System.resources.dll.
----------------------------------------
mscorlib.resources
Assembly-Version: 4.0.0.0.
Win32-Version: 4.8.4084.0 built by: NET48REL1.
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/mscorlib.resources/v4.0_4.0.0.0_de_b77a5c561934e089/mscorlib.resources.dll.
----------------------------------------

************** JIT-Debuggen **************
Um das JIT-Debuggen (Just-In-Time) zu aktivieren, muss in der
Konfigurationsdatei der Anwendung oder des Computers
(machine.config) der jitDebugging-Wert im Abschnitt system.windows.forms festgelegt werden.
Die Anwendung muss mit aktiviertem Debuggen kompiliert werden.

Zum Beispiel:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

Wenn das JIT-Debuggen aktiviert ist, werden alle nicht behandelten
Ausnahmen an den JIT-Debugger gesendet, der auf dem
Computer registriert ist, und nicht in diesem Dialogfeld behandelt.
[Last edited by snooty83, 2021-01-13 08:51]
2021-01-12 17:28
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 4159
Supporter
iconsnooty83:


Kann ich irgendwo die Beta Version 7.10.0.5 Downloaden?



JA
Gleiches Pinzip wie beim Download einer "älteren" Live Version. Man verändert einfach per Hand den Link.

https://www.mobiflight.com/tl_files/download/releases/beta/MobiFlightConnector-7.10.0.14.exe
Wenn du dort eben 7.10.0.5 schreibst würde er er die "5er" runterladen.

Somit Link für die 5er....
https://www.mobiflight.com/tl_files/download/releases/beta/MobiFlightConnector-7.10.0.5.exe

VORSICHT: Die Firmware ist unter umständen nicht "Downgrade Compatibel". Sollte es zwar sein aber nicht garantiert.
Somit wenn du eine ältere Version ziehst.... Die zwischenzeitlich neuerer die genutzt wurde aber eine neue Firmware auf das Mega packte.... Dann erkennt die Alte version dies nicht..... Denn die Firmware ist ja "neuer" als vom System vorrausgesetzt.
Sollte es dann ein Problem geben das die alte Version nicht mit der Firmware der neueren verträglich ist, gibt es Ärger.

Der sichere Weg falls es Problme gibt.... Die Boards per Hand löschen ( Settings als MFMC Backup machen !!!!) .
Somit erkennt MF das Board als "Jungfrau" und flashed genau die Firmware drauf die es aktuell braucht ( also im zweifel eine ältere die genau zu der Version passt die du gerade verwenden willst).
Good Luck !
2021-01-13 09:38
Avatar
snooty83
Posts: 2
Vielen Dank. Hat geklappt.

Zwischen der 7.10.0.5 und der 7.10.0.14 muss was gravierendes gewechselt worden sein. Die 7.10.0.14 funktioniert bei mir nicht. Ich kann keine Module auswählen. Bei der 7.10.0.5 klappt alles wie es soll.

Besten dank nochmals für den Link

Gruss Dani
2021-01-13 17:59
Go to page 1Go to page 112Go to page 3Go to page 2