MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
GeoffB
Posts: 7
I have a clone Mega and having problems uploading the parking brake LED example. In Windows control panel, device manager under ports the Mega appears as "USB -SERIAL CH340 (COM4)" but in MobiFlight, Settings, MobiFlight Modules in the Information section the Mega is shown as Port COM7. When I try to upload the LED module for this example I get a message "uploaded finished with error"

I've changed the port in device manager to COM7 but I still get the error message.

This is the information shown at the bottom of th eMF connector window for the last 2 times that I've loaded MF

14/02/2020 16:32:27(855): Something went wrong when flashing with command
"E:\arduino-1.8.11\hardware\tools\avr\bin\avrdude" -C"E:\arduino-1.8.11\hardware\tools\avr\etc\avrdude.conf" -patmega2560 -cwiring -P\\.\COM7 -b115200 -D -Uflash:w:"E:\Flight Sim\Mobiflight\firmware\mobiflight_mega_1_9_2.hex":i


14/02/2020 16:25:46(971): Something went wrong when flashing with command
"E:\arduino-1.8.11\hardware\tools\avr\bin\avrdude" -C"E:\arduino-1.8.11\hardware\tools\avr\etc\avrdude.conf" -patmega2560 -cwiring -P\\.\COM7 -b115200 -D -Uflash:w:"E:\Flight Sim\Mobiflight\firmware\mobiflight_mega_1_9_2.hex":i
14/02/2020 16:25:46(970): Firmware Upload Exit Code: 1
14/02/2020 16:25:46(639): RunAvrDude : -C"E:\arduino-1.8.11\hardware\tools\avr\etc\avrdude.conf" -patmega2560 -cwiring -P\\.\COM7 -b115200 -D -Uflash:w:"E:\Flight Sim\Mobiflight\firmware\mobiflight_mega_1_9_2.hex":i
14/02/2020 16:25:46(638): RunAvrDude : "E:\arduino-1.8.11\hardware\tools\avr\bin\avrdude"
14/02/2020 16:25:46(635): MobiflightModule.disconnect: Already Disconnected Default at COM7
14/02/2020 16:25:46(619): MobiflightModule.disconnect: Already Disconnected Default at COM7
14/02/2020 16:25:35(603): No updates necessary. Your version: 7.8.2.0, Latest version: 7.8.2
14/02/2020 16:25:35(416): Checking for updates
14/02/2020 16:25:35(281): MobiflightModule.disconnect: Disconnected Default at COM7
14/02/2020 16:25:29(223): MobiflightModule.connect: Connected to Default at COM7 of Type Arduino Mega 2560 (DTR=>True)
14/02/2020 16:25:28(874): MainForm() : Logger initialized Info

Is problem down to the Mega being a clone?
I'd be grateful for some advice.
Thanks
Geoff
[Last edited by GeoffB, 2020-02-14 17:41]
2020-02-14 17:24
icon