MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
logosjun
Posts: 2
https://youtu.be/OM3lHylCJkw

Please help me
I want to solve this problem

2015-12-18 오후 10:07:42: ExecutionManager.TestModeStop:Stopped test timer
2015-12-18 오후 10:07:36: Something went wrong when flashing with command
"C:\arduino-1.6.7\hardware\tools\avr\bin\avrdude" -C"C:\arduino-1.6.7\hardware\tools\avr\etc\avrdude.conf" -patmega32u4 -cavr109 -P\\.\COM19 -b57600 -D -Uflash:w:"C:\MobiFlightConnector\firmware\mobiflight_micro_1_1_0.hex":i
2015-12-18 오후 10:07:36: Exit Code: 1
2015-12-18 오후 10:07:36: RunAvrDude : -C"C:\arduino-1.6.7\hardware\tools\avr\etc\avrdude.conf" -patmega32u4 -cavr109 -P\\.\COM19 -b57600 -D -Uflash:w:"C:\MobiFlightConnector\firmware\mobiflight_micro_1_1_0.hex":i
2015-12-18 오후 10:07:36: RunAvrDude : "C:\arduino-1.6.7\hardware\tools\avr\bin\avrdude"
2015-12-18 오후 10:07:36: MobiflightModule.disconnect: Already Disconnected Default at COM19
2015-12-18 오후 10:07:36: MobiflightModule.disconnect: Already Disconnected Default at COM19
2015-12-18 오후 10:07:36: ExecutionManager.AutoConnectStop:Stopped auto connect timer
2015-12-18 오후 10:07:23: ExecutionManager.AutoConnectStart:Started auto connect timer
2015-12-18 오후 10:07:17: MobiflightModule.connect: Connected to Default at COM19
2015-12-18 오후 10:07:17: Exit Code: 0
2015-12-18 오후 10:07:06: RunAvrDude : -C"C:\arduino-1.6.7\hardware\tools\avr\etc\avrdude.conf" -patmega2560 -cwiring -P\\.\COM19 -b115200 -D -Uflash:w:"C:\MobiFlightConnector\firmware\mobiflight_mega_1_4_1.hex":i
2015-12-18 오후 10:07:06: RunAvrDude : "C:\arduino-1.6.7\hardware\tools\avr\bin\avrdude"
2015-12-18 오후 10:07:06: MobiflightModule.disconnect: Already Disconnected Default at COM19
2015-12-18 오후 10:07:06: MobiflightModule.disconnect: Already Disconnected Default at COM19
2015-12-18 오후 10:07:06: ExecutionManager.AutoConnectStop:Stopped auto connect timer
2015-12-18 오후 10:07:03: MobiflightModule.disconnect: Disconnected Default at COM19
2015-12-18 오후 10:06:57: MobiflightModule.connect: Connected to Default at COM19
2015-12-18 오후 10:06:52: MainForm() : Logger initialized Info
2015-12-18 14:20
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1443
It's interesting to see, that the micro firmware shows up.
The first attempt actually has a nice looking exit code "0".

I hope it's not a problem with the asian characters :confused:

What kind of board do you use exactly?
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2015-12-18 22:42
Avatar
logosjun
Posts: 2
Thank you to answer :) :)

I used the Arduino Mega 2560

You can know look at the YouTube video link

And after a firmware upload can see that the device changes to UNKNOWN

Arduino Mega 2560 board I have is there is no problem :rolleyes:
2015-12-19 04:34
Avatar
DocMoebiuz
Moderator
From: NW of KPWK, United States
Posts: 1443
I watched the video.
The first part looks right.
Can you upload a normal Arduino Sketch again, e.g. the blink example, confirm that it works and then try again to upload the firmware via MobiFlight?

Then only do it once (in the log output there is exit 0, which is the correct result value for the update) - and then restart the MobiFlight Connector. Do not click again on the Update Firmware Item in the context menu.
Have a great day!
Sebastian

MobiFlight - Simply build your own home cockpit for your favorite flight sim - FSX, Prepar3D (FSUIPC), X-Plane (XPUIPC)
2015-12-19 10:12
Avatar
aneeskhan187
Posts: 2
I am having a similar problem and unable to add a new device. It used to work fine and then suddenly this happened. Please Help
2020-05-31 08:24
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3524
Supporter
Hi

This Topic is 5 Years old.... Since that point Mobiflight get patched over 20 times and is changed internal a lot of times.
To help you please exactly report what happen and whats your problem..... And for next time please open a own Topic and not refresh long time dead threads.

Basic Workflow.
If Mega make trouble a good idea is a Reset of the Board.
Use the EEPROM Clear sketch via Arduino IDE to completly delete the Memory.... Then the Board is like brand new and you can flash firmware again and test.
Mostly this solve a lot of problems.

Report if this helps.... If not please tell us more details !
Good Luck !
2020-05-31 15:00
Avatar
aneeskhan187
Posts: 2
The eeprom clear sketch did the tricked for me. Man, I am extremely thankful to your reply and for solving my problem, Thanks a bunch and may you have a great day.
2020-05-31 19:39
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 3524
Supporter
No Problem.... your welcome.
Have a great day !
Good Luck !
2020-05-31 23:13
icon