MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
auransbey
From: ROME, Italy
Posts: 50
Hello everyone .
as often happens I need your kind clarification.
at this moment my homecockpit works with 5 MEGA and I manage 1 EFIS (1mega) + 1 MCP (2mega) + MIP (2mega).
I am continuing my hard work and I plan to use 15 MEGA at the end.
everything is for the best.
a strange thing happens.
until a few days ago I could work with only 1 or 2 megs connected in USB and leave the others disconnected.
A mask appeared in MF that warned me of the lack of connection of the other mega but everything worked fine.
Today I realized that disconnecting some mega MF does not start.
if I try to TEST it stops as soon as it reaches one of the disconnected mega.
I don't understand what the change is due to.
I just have to say that these days I have disconnected 2 monitors, but I don't understand what it has to do.
as always many thanks for this wonderful tool and for your kindness.
MF - simply wonderful !!
2019-05-25 20:38
Avatar
StephanHo
From: EDDG, Germany
Posts: 1328
Supporter
Hi auransbey,

it is normal for MF to tell you when starting up if one ore modules are not connected. These are the orphaned modules MF did not recognize at startup and may need to be (re) assigned.
At startup, it only looks for the modules that are in the last loaded file (mcc-file), configs that you have assigned to modules. If none of the modules are connected, no message will be sent.

If now not all modules are connected, which should be connected and you press MF at startup, then it may be that MF stops immediately. This depends on the configs that affect the missing module. If a module has e.g. preconditions or outputs, such termination occurs. This explains why MF ran in one constellation and not in the other.

The change of monitors or other hardware does not effect MF.

Hope, this explains the root cause with your system.
Grüße,
Stephan
2019-05-26 00:56
Avatar
auransbey
From: ROME, Italy
Posts: 50
PERFECT.
I understood the reason for the problem.
indeed in mega 3 and 4 (MCP) there are many preconditions for the 6 displays as you know.
So everything is ok.
I will always leave all the mega connected even in the future.
I thank you very much for your valuable advice and explanations.
MF - simply wonderful !!
2019-05-26 15:12
icon