MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
pwilliamssa@yahoo.com
Posts: 5
Trying to run gear lights and caution lights via MobiFlight. I have XPUIPC in my plugins folder. I have MobiFlight Configured with my UNO board. I can hit test on each function and the LED illuminates. Now I start XPlane11 and MobiFlight shows its running with good connection to my UNO and XPUIPC but nothing from the LED's. Do I need to add something to the XPUIPC ini file? When I look at XPUIPC it showns no network connections? Running locally on same PC. IP Address is 10.10.0.200 and that's what I have in the .ini.

TIA
2018-11-09 03:48
Avatar
StephanHo
From: EDDG, Germany
Posts: 1269
Supporter
Hi pwilliamssa,

welcome to MobiFlight!

I myself does not use X-Plane, so I can only guess that.
The gear-lights are not in the offset list. So try the standard-Offset from FSX (0x0BEC [nose], 0x0BF0 [right] and 0x0BF4 [left]) where the value is 0 for full up and 16383 for full down (locked). If the value is 0 the LEDs are off, if value is >0 and <16383 gear is in transit (red LED on) and if value is 16383 gera ist locked down (LED green on - LED red off)

The MASTER CAUTION in XPUIPC is the offset 0x78ED and the value is 23. But with this offset you can set the MASTER CAUTION, not the LED.

You should ask your issue in the relevant forum.
Grüße,
Stephan
2018-11-09 19:12
Avatar
pwilliamssa@yahoo.com
Posts: 5
Thank you for the reply. MobiFlight pulled those values when I set up the mappings. When I get everything running I have the Green check on Modules and FSUIPC. Should I see values populating in the FSUIPC Value and Output Value columns when everything is running?
2018-11-10 00:33
Avatar
pwilliamssa@yahoo.com
Posts: 5
I have the leds on pin 3-9 on the Arduino. When I mapped I used (R/N/L) gear moving for red led pins and (R/N/L) gear extended for green led pins. The Offset values where as you posted. For the handle I cheated and used the R moving. (How do I upload/post a jpg???) however, I'm a little lost on the values part... "where the value is 0 for full up and 16383 for full down (locked). If the value is 0 the LEDs are off, if value is >0 and <16383 gear is in transit (red LED on) and if value is 16383 gera ist locked down (LED green on - LED red off)" But again, I'm not seeing any values in the FSUIPC Value and Output Value columns of MobiFlight when running.
2018-11-10 00:52
Avatar
StephanHo
From: EDDG, Germany
Posts: 1269
Supporter
Exactly!

The FSUIPC value is the value from the simulation and the Output value is the one from MF. This value can be influenced by the transform field.
Grüße,
Stephan
2018-11-10 00:54
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 2578
Supporter
Hey Guys... I Think here are Multiple Problems.

1. Wrong Offset Information by Stephan:
iconStephanHo:


The MASTER CAUTION in XPUIPC is the offset 0x78ED and the value is 23. But with this offset you can set the MASTER CAUTION, not the LED.


This is NOT the XPUIPC Offset.... This is the Input Offset (FSUIPC) for the Jeehell Airbus FMGS in FSX/P3D
(Please correct me if this is also useable in XP11 now... As i know Jeehell works for P3D/FSX only)

***
2. Wrong Board
You say you use a UNO. I think this is not your Problem here ( Cause you say you not recive data from XPlane) .
BUT : Note that UNO is no longer supported official by Mobiflight. Sebastian still let the code alive ...If it work for you, your lucky.... If not its your problem.
So i recommend to prevent issues in the future to swap for a MEGA Arduino. Thats 100% supported Now and in the future !

3. Your Problem:
Please basicly check if you recive Data from Xplane !
Simply make the Parking Brake Tutorial!
Your right....
In The Mobiflight OUTPUT Tab you should see (while RUN mode is active) the Value in the collums Right of your Config.
FSUIPC Valie is the RAW Value read out from Sim.... The Other Value to the right is the Output Value to your Device ( Maby different through a Transform/Compare etc. )
So... If you run Mobiflight (RUN Mode) and your run xplane.... And there is NO DATA in this collums then your connection is wrong.


In that case...
Please get sure your XPUIPC Version is good and work correct. ( I not know these IP Adress Stuff... Please google for that or read the XPUIPC Forums)

Alternate:
To Learn and test Mobiflight the FSX is the most practicable plattform.
If you have a FSX/P3D version i recommend to test there.... If you then know the stuff from Mobiflight and the logics then its more easy to implement this in Xplane !
Good Luck !
2018-11-10 07:39
icon