MobiFlight Community Support

Welcome to the forum for MobiFlight! Feel free to reach out to the community in case you have questions, issues or just want to share great ideas or details about your latest home cockpit project.

You like MobiFlight? Donate via PayPal and support the MobiFlight development. Thanks! 

icon
Avatar
oltv
Posts: 2
Hey Mobiflight Community,

I would like to integrate my newly build cockpit hardware into FSX Steam Edition.
First of all, id like to say that I am really impressed by the Mobiflight Software and the ease of use!
I started with the parking brake example. So far so good: the arduino mega integration worked perfectly and the button press gets recognized by the mobiflight software. Unfortunately there seems to be a problem with the writing process to the FSUIPC.

That is my setup:
- Newest Version of Mobiflight Connector 7.5.0
- FSX Steam Edition either in Steam folder (Program x86) or on external Drive (tried with both)
- Standard FSX A321 plane
- Windows 10
- Arduino Mega with switch on Pin 40
- Input on pin 40 is setup for parking break

That is happening:
- Mobiflight Connector opens just fine and accepts arduino mega (Green checkmark)
- As soon as I launch FSX, the other green checkmark (FSUIPC connection) comes on
- After loading the plane and starting mobiflight I tried to switch the parking-brake switch on my arduino:
- TX Led blinks
- Mobiflight pops up an error msg and tells me that it disconnected from FSUIPC
- Error msg:
Error on config execution. FSUIPC Error #12: FSUIPC_ERR_SENDMSG. Error sending message to FSUIPC.

Notes:
- I tried to open Mobiflight in Admin mode, but it was not able to establish a connection to FSUIPC at all (no green checkmark)
- I tried to open FSX from a different drive but that did not change anything

I really hope you guys can help me on that, it is now day 3 that i am trying to figure out whats wrong. I am looking forward to see mobiflight and my cockpit in action!

Servus from Munich!
[Last edited by oltv, 2018-11-02 16:03]
2018-11-02 15:58
Avatar
pizman82
Moderator
From: ETSI, Germany
Posts: 2916
Supporter
Hi
Welcome to Mobiflight ( Und Servus nach München :thumbup: )

Sounds like a connecting Problem..... Badly i can not test on your computer to find the issue directly.

Some basic facts:

1. Simulator and Mobiflight should not run in a "Secured" Folder like "/Programmfilesx86 " etc. It is always recommend to install all Stuff in "own" folders.... Much better in a own partion of a harddisc or in best way on a own SSD Drive (indipendent from the Windows System)

2. Admin Mode is not basicly recommend by Sebastian and Mobiflight.... But Myself i run all Programms ( Whatever my Firefox Explorer, too) always in Admin Mode. Have never Problems with it.
Important: Your Mobiflight and your SIM must be in same Status.... If one is ADMIN then the other must be ADMIN, too.... Or Both should be non Admin. Just get sure you not mix it.

3. FSUIPC
I not read somethin about you "Update" your FSUIPC. Please get newest version from http://www.schiratti.com/dowson.html (V 4.971 at current moment Nov2018)

4. Try to change your sequence while starting: Maby the problem is you start MF before the Sim.... Simply start for testing Sim in front of Mobiflight.


Please report experience!

EDIT:
You said you have TWO FSX-SE installations on your system. "Maby" this also can create a problem. Get sure your FSUIPC is in correct Simulator.... Or maby delete the not used one.
Good Luck !
2018-11-02 16:44
Avatar
StephanHo
From: EDDG, Germany
Posts: 1365
Supporter
Hi oltv,

Welcome to MobiFlight!

The main problem with why something with MF and FSX does not work is that it is installed in system folders specially monitored by Windows.

For a short or long time, you will not be spared the trouble of installing both the FSX and MF in another folder, better still, on a different drive. The installation should be done with admin rights (in both cases).

If your FSUIPC does not report to MF, it may be due to these causes.

To be on the safe side, uninstall FSX and MF and reinstall on another drive with admin rights. I know that's tedious and time consuming, but do it sooner than later, especially if you're planning more addons.

FSUIPC is usually freeware. But I recommend anyone who spends a few euros for the registration because then a wealth of features are available. I do not know anyone who regretted the registration.

If you have reinstalled, try again. If it still does not work, which I do not go out, just sign up here again. You would be the first one who could not be helped here.

EDIT: again a temporal overlap
Grüße,
Stephan
2018-11-02 16:55
Avatar
oltv
Posts: 2
Thanks for the quick help guys!

Im gonna try it out as soon as I got the time!
2018-11-02 18:55
icon